易语言添加防修改版权代码


凡是编写软件的朋友,都会遇到一种问题:版权被别人修改。

自己辛辛苦苦编写的软件,被别人轻易修改成了自己,想想确实很令人生气。

[PS:易捷博客也修改过别人的软件,在这里要致歉。 ]


今天易捷博客网教大家怎么在代码中防止别人修改版权。 

所需要的软件:易语言    BASE64字符转换工具 

软件会放在文章底部。


开始我们的教程吧 。

1、首先使用易语言新建一个源码,标题写下:易捷博客网 www.vxia.net

QQ截图20151117141604.png


2、在程序中,添加模块 -  BASE64编码模块

QQ截图20151117141836.png


3、打开字符转换工具,输入你要转码的文字,复制下来,留以备用。

比如 “易捷博客网 www.vxia.net” 转换后 为 “0te93bKpv83N+CB3d3cueWN5amtqLmNvbQ==

QQ截图20151117142229.png


4、写代码,只需要一个判断语句即可。判断当前窗口的标题是否为作者的。

 如果标题正确,继续正常执行;如果不正确,被别人修改了,弹出信息框,关闭软件。

QQ截图20151117143101.png


代码:


.版本 2
.支持库 eAPI

.程序集 窗口程序集1
.程序集变量 ycyjkj, 文本型

.子程序 __启动窗口_创建完毕

ycyjkj = 到文本 (BASE64解码 (“0te93bKpv83N+CB3d3cueWN5amtqLmNvbQ==”))

.判断开始 (_启动窗口.标题 = ycyjkj)

.默认
    信息框 (“非法软件!请重新下载!”, #错误图标, )
    打开指定网址 (“http://www.vxia.net”)
    销毁 ()
.判断结束



5、我们把标题修改下看看效果。标题就修改为 “ 易捷博客” 吧。这就是效果图

QQ截图20151117143201.png



大家可以使用软件或手动修改试下,易捷博客测试没问题。



BASE64编码模块 BASE64字符转换工具 打包下载:

百度云盘:http://pan.baidu.com/s/1mgo2QAc 密码:6rtc

360云盘:http://yunpan.cn/cL2QVEHH7jSLe  访问密码 9907


源码及成品下载:

百度云盘:http://pan.baidu.com/s/1jGfJ4fc 密码:9132

360云盘:http://yunpan.cn/cL2QrWGxauiDL  访问密码 b712


经测试:版权修改软件 http://www.vxia.net/post-750.html 不能修改成功。




标签: 破解

内容版权声明:除非注明,否则皆为本站原创文章。

转载注明出处:http://www.vxia.net/post-749.html

相关推荐

你肿么看?

◎欢迎参与讨论,请在这里发表您的看法、交流您的观点。