易语言两种软件注册方式 附源码 - 微夏博客网 - 致力于网络优秀资源的分享、交流!

易语言两种软件注册方式 附源码

由 ℡若兮相言 于 2015-1-1 15:15 Thursday 发表,已有2997人观看。


    关于软件注册,有两种简单的方式


    一种是直接判断注册码是否为指定的一个字符串,如果字符串正确,则载入正确窗口;如果字符串错误,弹出错误提示器,并关闭软件。这种属于是最简单的一种注册方式


    QQ截图20150101152546.jpg


    一共分为两个窗口,源码分别为:

    窗口程序集1 源码为:


    .版本 2
    
    .程序集 窗口程序集1
    
    .子程序 _按钮1_被单击
    .版本 2
    
    .如果 (编辑框1.内容 = “www.vxia.net”) 可视 = 假 载入 (窗口1, , 假) .否则 信息框 (“注册码错误,请检查重新输入!”, #错误图标, “注册失败”) .如果结束


    窗口程序集2 源码为:


    .版本 2
    
    .程序集 窗口程序集2
    
    .子程序 _窗口1_将被销毁
    
    结束 ()
    



    下载地址:


    普通软件注册源码及成品     提取码:d75a                普通软件注册源码及成品


    第二种软件注册方式,就相当来说比较麻烦的一种了,也属于是使用的比较多的一种方式。  根据硬盘的身份码,生成机器码,每个机器都对应着一个注册码。  如图所示。


    QQ截图20150101152918.jpg


    同样两个程序集,

    窗口程序集1源码为:


    .版本 2
    
    .程序集 窗口程序集1
    .程序集变量 本机编码, 整数型
    .程序集变量 对比文本, 文本型
    
    .子程序 __启动窗口_创建完毕
    
    编辑框1.内容 = 序列号获取 ()
    ' 易捷博客网 www.vxia.net
    ' 致力于网络优秀资源的分享、交流!
    
    .子程序 序列号获取, 文本型
    .局部变量 序列号, 整数型
    .局部变量 i, 整数型
    .局部变量 结果, 文本型
    .局部变量 临时文本, 文本型
    
    序列号 = 取整 (取硬盘特征字 ())
    .如果真 (取符号 (到数值 (序列号)) = -1)
        序列号 = -序列号
    .如果真结束
    临时文本 = 字节集到十六进制 (到字节集 (序列号))
    .计次循环首 (取文本长度 (临时文本), i)
        .如果 (i % 2 = 0 且 i ≠ 取文本长度 (临时文本))
            结果 = 结果 + 取文本中间 (临时文本, i, 1) + “-”
        .否则
            结果 = 结果 + 取文本中间 (临时文本, i, 1)
        .如果结束
    
    .计次循环尾 ()
    返回 (结果)
    
    .子程序 _按钮1_被单击
    .局部变量 临时文本, 文本型
    .局部变量 i, 整数型
    
    本机编码 = 字节集到整数 (十六进制到字节集 (子文本替换 (编辑框1.内容, “-”, “”, , , 真))) + 到整数 (386580373) × 到整数 (38658037) ÷ 到整数 (656536055)
    对比文本 = 字节集到十六进制 (到字节集 (本机编码))
    .判断开始 (编辑框2.内容 ≠ 对比文本)
        信息框 (“您输入的注册码不正确,请重新输入!”, #错误图标, “注册失败”)
    .默认
        可视 = 假
        载入 (窗口1, , 假)
    .判断结束
    
    窗口程序集2 源码为:



    .版本 2
    
    .程序集 窗口程序集2
    
    .子程序 _窗口1_将被销毁
    
    结束 ()
    


    下载地址:


    机器码软件注册源码及成品     提取码: f94e            机器码软件注册源码及成品


    但是,有机器码了,也是需要注册码的。注册码从哪里来?也是需要计算的。所以计算注册码,也需要一个软件。



    QQ截图20150101153408.jpg


    注册机源码为:


    .版本 2
    
    .程序集 窗口程序集1
    .程序集变量 编码, 整数型
    
    .子程序 _按钮1_被单击
    
    编辑框2.内容 = “”
    .如果 (编辑框1.内容 ≠ “”)
        编辑框2.内容 = 生成注册码 (编辑框1.内容)
    .否则
        信息框 (“请输入序列号”, 0, )
    .如果结束
    
    
    .子程序 __启动窗口_创建完毕
    
    ' 易捷博客网 www.vxia.net
    ' 致力于网络优秀资源的分享、交流!
    
    .子程序 生成注册码, 文本型
    .参数 序列号, 文本型
    .局部变量 特征, 整数型
    
    特征 = 到整数 (386580373) × 到整数 (38658037) ÷ 到整数 (656536055)
    编码 = 字节集到整数 (十六进制到字节集 (子文本替换 (序列号, “-”, “”, , , 真))) + 特征
    返回 (字节集到十六进制 (到字节集 (编码)))
    
    下载地址:



    易语言注册机源码及成品     提取码:e066            易语言注册机源码及成品



    在这里要注意了!源码里的特征,那些数字,要跟你写的需要注册的软件源码里的完全一样,不一样的话,会注册不成功。

    当然了,特征括号里的,不一定要是数字,也可以是字符串。如图所示。这样也是可以的。

    QQ截图20150101154026.jpg


    注:第二种机器码注册方法的话,需要右键以管理员身份运行。

    如果用第二种方法的话,需要用到一个模板---Super-EC7.0正式版.ec   在这里给大家打包上。


    模块下载地址:


    易语言模块Super-EC7.0正式版     提取码:070d            易语言模块Super-EC7.0正式版


    试着编写下你自己的软件吧!


    接下来将会为大家介绍怎么破解这类的注册软件。


    易捷博客网 www.vxia.net 致力于网络优秀资源的分享、交流!


赞赏
X
赞赏方式:
  • 支付宝
  • 微信

打开支付宝扫一扫

标签: 注册 易语言




↓↓↓↓↓你可能在找下面的内容↓↓↓↓↓

特别申明:若无说明,文章均为原创,转载时请注明本文地址,谢谢合作!
本文链接:
评论:
香港虚拟主机 2015-01-03 14:20
走过路过,凑一凑,完全没看懂的节奏,专业不对口啊!

℡若兮相言 2015-01-03 19:16
@香港虚拟主机:易语言的一些小技巧~~欢迎互访~

网赚了 2015-01-03 13:25
写得不错 {酷}

℡若兮相言 2015-01-03 19:18
@网赚了:你的网站也很不错,都是些很好的资源~

王语双个人站 2015-01-02 18:21
外行路过,继续支持。PS:网页在火狐下错位,左侧看不完。

℡若兮相言 2015-01-02 20:06
@王语双个人站:已及时修改~感谢建议~~{献花}

同盟源 2015-01-01 20:00
学习了,没想到博主易语言也这么牛{大笑}

℡若兮相言 2015-01-01 20:19
@同盟源:很久以前的,现在很少玩这了

发表评论: