网页控制易语言软件更新 附源码


当自己开发了一个软件之后,以后做维护,需要更新的时候,怎么提示已经使用的用户呢?

这时候需要在源码里面添加一些代码,让制作的软件,在启动的时候,先读取网站的资源文件,看下有没有符合的版本,再进行执行!

软件源码需要 精易模块,我会在附件里打包给大家。


易捷博客网也做了一个很简单的小案例,首先在 http://www.vxia.net/html/update.txt 里面写入了几句话



qian.2.hou

易捷博客网 www.vxia.net


在 qian.2.hou 中,最主要的就是 这个 2 数字 

来看下软件的具体源码


.版本 2
.支持库 internet
.支持库 eAPI

.程序集 窗口程序集1
.程序集变量 访问, 文本型
.程序集变量 前置, 整数型
.程序集变量 后置, 整数型
.程序集变量 读取, 文本型

.子程序 __启动窗口_创建完毕

访问 = 到文本 (HTTP读文件 (“http://www.vxia.net/html/update.txt”))
前置 = 寻找文本 (访问, “qian.”, 1, 假)
后置 = 寻找文本 (访问, “.hou”, 1, 假)
读取 = 取文本中间 (访问, 前置 + 5, 后置 - 前置 - 5)


.如果真 (读取 = “1”)
    信息框 (“软件有最新版本,建议更新!”, 0, )
    打开指定网址 (“http://www.vxia.net”)
    结束 ()
.如果真结束
.如果真 (读取 = “2”)
    信息框 (“此版本为最新版!”, 0, )
.如果真结束


在启动软件的时候,软件先读取这个txt文本,当读取到1时,会提示软件有更新,当读取到2时,会提示是最新版。


QQ截图20150517092518.png




赞赏
X
赞赏方式:
  • 支付宝
  • 微信

打开支付宝扫一扫

内容版权声明:除非注明,否则皆为本站原创文章。

转载注明出处:http://www.vxia.net/post-548.html

相关推荐