[股票]通信达 智能MACD指标 源代码 附使用教程 - 微夏博客网 - 致力于网络优秀资源的分享、交流!
论坛模板:http://addon.discuz.com/?@zhanzhuai_am.template.57926
  • 首页
  • 其它
  • [股票]通信达 智能MACD指标 源代码 附使用教程

[股票]通信达 智能MACD指标 源代码 附使用教程

由 ℡若兮相言 于 2015-5-4 17:42 Monday 发表,已有2242人观看。


    智能MACD指标跟系统自带的数据没有什么变化,只是使用起来更直观!


    首先确认你的版本为通信达软件

    QQ截图20150504174230.png


    源码如下:


    DIFIF1:=EMA(CLOSE,12) - EMA(CLOSE,26);
    DEAEA1:EMA(DIFIF1,9);
    MACD1:=2*(DIFIF1-DEAEA1),STICK;
    MACD2:=EMA(MACD1,3);
    STICKLINE(MACD1>MACD2 AND MACD1>0,0,MACD1,1,0),COLORRED;
    STICKLINE(MACD1>MACD2 AND MACD1<0,0,MACD1,1,0),COLORGREEN;
    STICKLINE(MACD1<MACD2,0,MACD1,1,0),COLORCBCBC0;
    STICKLINE(MACD1>=0 OR MACD1<=0,0,0,50,1),COLORWHITE;
    DIFIF1,COLOR33FF33;
    DEAEA1,COLORYELLOW;
    MACD:MACD1,NODRAW,COLORMAGENTA;
    强:IF(DIFIF1>=DEAEA1,DIFIF1,DRAWNULL),COLORRED,LINETHICK2;
    弱:IF(DEAEA1>=DIFIF1,DEAEA1,DRAWNULL),COLORFF9900,LINETHICK2;
    DRAWICON(CROSS(DIFIF1,DEAEA1),DEAEA1-0.02,1);



    使用教程如下:

    我的版本是长城证券烽火版,只要是通信达版本的,都可以这样使用。


    1、系统设置--公式系统--公式管理器

    QQ截图20150504174213.png


    2、左侧选择 趋势型 ,然后点击 新建

    QQ截图20150504174311.png


    3、输入名称“智能MACD” 公式类型选择“趋势型” 画线方法为 “副图” 然后把源码复制到里面,点击“测试公式”。如果正确的话,会提示测试通过。最后直接点右上角处的“确定”即可添加 智能MACD。

    QQ截图20150504174509.png


    4、在使用的时候,直接输入 “智能MACD” 拼音的大写首字母就可以,"ZNMACD" 软件会自动显示,然后直接回车即可。

    QQ截图20150504175254.png




标签: 代码 股票




↓↓↓↓↓你可能在找下面的内容↓↓↓↓↓

特别申明:若无说明,文章均为原创,转载时请注明本文地址,谢谢合作!
本文链接:

发表评论: